Running qemu tests on RISC-V

Tom Rini trini at
Wed Feb 9 22:20:33 CET 2022

On Wed, Feb 09, 2022 at 11:20:51PM +0300, Alper Nebi Yasak wrote:
> On 07/02/2022 19:49, Tom Rini wrote:
> > And as an aside, if anyone has tips on changes that would need to be
> > made to our Dockerfile so that some of those tools that let you run app
> > from a container "normally" would work with our container, that'd be
> > handy and appreciated.
> I also don't know which tools you mean, but I tried to get a shell in
> the container to experiment and this worked:

What I was thinking of was based on reading:
as part of trying out b4 for my workflow (didn't fit for most things,
quite handy for a few tho).

>   docker run --privileged --volume="$(pwd):/build" --interactive --tty \
>       trini/u-boot-gitlab-ci-runner:focal-20220113-03Feb2022 \
>       /bin/bash -i
> One thing I noticed is that when I omit the version of the container, it
> tries to download a version named "latest" and fails, and it looks like
> you should publish/update that whenever you upload a new build.

I've never populated a "latest" tag, but probably should, yes.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 659 bytes
Desc: not available
URL: <>

More information about the U-Boot mailing list