[U-Boot] [PATCH 6/6] arm: mx5: Add support for DENX M53EVK

Marek Vasut marex at denx.de
Sun Apr 21 04:32:59 CEST 2013


Dear Fabio Estevam,

[...]
> > +u32 get_board_rev(void)
> > +{
> > +       struct iim_regs *iim = (struct iim_regs *)IMX_IIM_BASE;
> > +       struct fuse_bank *bank = &iim->bank[0];
> > +       struct fuse_bank0_regs *fuse =
> > +               (struct fuse_bank0_regs *)bank->fuse_regs;
> > +       int rev = readl(&fuse->gp[6]);
> > +
> > +       return (get_cpu_rev() & ~(0xF << 8)) | (rev & 0xF) << 8;
> > +}
> 
> Can't you just remove this get_board_rev() from the board file and use
> the generic one instead?

There's no such thing for mx5, only for mx6.

I fixed the rest, but I left the multiline comments. It's the same on m28 and I 
consider it more readable.

Best regards,
Marek Vasut


More information about the U-Boot mailing list