[U-Boot] [PATCH v3 0/19] Allow images to work on sandbox

Simon Glass sjg at chromium.org
Mon Apr 22 14:51:28 CEST 2013


This series adjusts the image code to work with sandbox and prepares it for
verified boot to come later.

The primary goal here is to get image loading to work on sandbox, which is
mostly a set of fairly minor changes such as using map_sysmem() instead of
just a cast when converting from a U-Boot address to a pointer. Since
common/image.c runs to over 3000 lines and half of it is FIT-related code
behind an #ifdef, this code is moved into a new image-fit.c file.

This series depends on the sandbox generic board series:

    sandbox: Generic board support and other improvements

Changes in v3:
- Update notes to note that generic board support has now landed
- Split out image improvements into a separate series

Changes in v2:
- Change hash_block() to use an unsigned int len
- Clarify use of output_size parameter to hash_block()
- Fix line continuation problem
- Fix checkpatch checks about parenthesis alignment
- Rebase on previous patches
- Rebase on previous patches
- Rebase on previous patches
- Add IMAGE_ENABLE_IGNORE to avoid #ifdef around ignore property handling
- Rename commit message to say "function" instead of "function"
- Rebase on previous patches
- Put err_msgp strings on a single line
- Rebase on previous patches
- Put params before description in fit_conf_get_prop_node() comment
- Rebase on previous patches
- Rebase on previous patches
- Fix checkpatch checks about parenthesis alignment

Simon Glass (19):
  env: Fix minor comment typos in cmd_nvedit
  Add minor updates to README.fdt-control
  hash: Add a way to calculate a hash for any algortihm
  bootstage: Don't build for HOSTCC
  mkimage: Move ARRAY_SIZE to header file
  libfdt: Add fdt_next_subnode() to permit easy subnode iteration
  image: Move timestamp #ifdefs to header file
  image: Export fit_check_ramdisk()
  image: Split FIT code into new image-fit.c
  image: Move HOSTCC image code to tools/
  image: Split hash node processing into its own function
  image: Convert fit_image_hash_set_value() to static, and rename
  image: Rename fit_image_check_hashes() to fit_image_verify()
  image: Move hash checking into its own function
  image: Move error! string to common place
  image: Export fit_conf_get_prop_node()
  image: Rename fit_add_hashes() to fit_add_verification_data()
  image: Rename hash printing to fit_image_print_verification_data()
  sandbox: image: Add support for booting images in sandbox

 common/Makefile        |    1 +
 common/cmd_bootm.c     |   25 +-
 common/cmd_fpga.c      |    2 +-
 common/cmd_nvedit.c    |    4 +-
 common/cmd_source.c    |    2 +-
 common/cmd_ximg.c      |    2 +-
 common/hash.c          |   23 +
 common/image-fit.c     | 1497 ++++++++++++++++++++++++++++++++++++++++++
 common/image.c         | 1679 ++----------------------------------------------
 common/update.c        |    2 +-
 doc/README.fdt-control |    9 +-
 include/bootstage.h    |    5 +-
 include/hash.h         |   22 +
 include/image.h        |   55 +-
 include/libfdt.h       |   17 +
 lib/libfdt/fdt.c       |   12 +
 tools/Makefile         |    4 +
 tools/aisimage.c       |    1 -
 tools/fit_image.c      |    2 +-
 tools/image-host.c     |  213 ++++++
 tools/mkimage.h        |    2 +
 21 files changed, 1903 insertions(+), 1676 deletions(-)
 create mode 100644 common/image-fit.c
 create mode 100644 tools/image-host.c

-- 
1.8.2.1



More information about the U-Boot mailing list